DSC / ABS ausgefallen, Sensorfehler - illegaler Code, potenzielle LÖSUNG: Ablagerung im SZL

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • DSC / ABS ausgefallen, Sensorfehler - illegaler Code, potenzielle LÖSUNG: Ablagerung im SZL

      Hey,

      mein Dodo stand heute den ganzen Tag in der prallen Hitze und als ich vorhin losgefahren bin, fiel direkt DSC aus. Zudem geht das Lenkrad nicht mehr auf "Nullstellung" von alleine und der Blinker bleibt dauernd an. Nachdem ich etwas gefahren bin verschwand der Fehler aufeinmal wieder, lenkung war normal, Blinker funktionierte auch wieder.

      Mein Tester sagt:

      -DSC: F-Can SZL Lenkwinkelsensor: Sensorfehler - Illegaler Code (94B5)
      -DSC: Lenkwinkelsensor Intern (5E43)
      -EPS - Botschaft vom PT-Can (Lenkwinkel oben, ID=0x4h) (D515)

      Ich habe bemerkt, dass der Fehler beim langsamen rechts-Abbiegen wieder auftritt. Also wenn ich beispielsweise unter 20kmh abbiege in eine Straße rechts, dann fällt DSC wieder aus und die Lenkung fühlt sich viel weicher an und geht nicht zurück in Nullstellung. Auch der Blinker bleibt an und geht nicht wieder aus (sicherlich wegen dem Lenkwinkelsensor-Müll).

      Eventuell noch relevant: Vorne links habe ich glaube ich nen halb-defekten Querlenker oder sowas, kann der zum Ausfall des Systems führen?

      Hat irgendwer einen Ansatz? Bei BMW brauchts wieder 2 Wochen, bis ich nen Termin bekomme..

      EDIT: Lösung ist vermutlich eine verschmutzte Disk im Innern des SZL, weitere Infos im Thread selber!

      ""

      saftig cre

      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von lked ()

    • gleiche problem

      Hallo,

      mein Auto stand auch ganze Woche in der Hitze, und hab das gleiche Problem!

      wenn ich den Wagen abstelle, und warte ein bissl, dann wieder losfahre, geht es weg.
      ich hab meinen Automechaniker angerufen, und hat grad gesagt, mach dir kein Stress, kein Panik,
      irgendwas Sensor spinnt, er wird alles überprüfen.

      Also, ich bin ruhig jetzt,.....
      mach dir auch kein Stress!!!!

      Meiner ist a 320si, baujahr 2006, 77tkm drauf.


      Mfg.
      Katharine aus Ingolstadt

    • Danke für deine Meldung. Das gleiche hab ich auch. Mal kann ich auch ne ganze Autofahrt ohne Probleme fahren und dann fällt wieder alles spontan aus.

      Es wird das SZL (Schaltzentrum Lenksäule) sein.. In dem Teil befindet sich der Lenkwinkelsensor (Infrarot LED + Drehscheibe). Entweder ist die Scheibe verschmutzt (eventuell Dämpfe von der Hitze, verzogen) oder die Lötstellen haben einen Knacks weg. Oder das Teil ist einfach hin.

      Bei den ersten 2 Versionen kann man folgendes probieren, habe ich im Internet gefunden:

      bimmerfest.com/forums/showthread.php?t=536369

      Das werde ich ausprobieren. Habe aber zusätzlich auch schon ein neues SZL bei eBay gekauft, welches ich einbauen kann...falls die Reinigung nichts bringt :) Berichte mal, sobald du etwas neues weisst.

      Auffällig ist einfach, dass offenbar wirklich einen Zusammenhang mit der Hitze gibt...

      saftig cre

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von lked ()

    • Ich hab auch im Internet gesurft, ob jemand vielleicht auch das gleiche Problem hat.
      Dann hab ich dein Post gesehen.
      Es ist ärgerlich, aber ich dachte auch, es hängt zusammen mit der Hitze.
      hab ebay geschaut, diese SZL kostet eigentlich nicht so viel... trotzdem nervig :S

      1. Juli habe ich einen Termin.. schau ma mal was kommt :)
      heute hab ich mein baby gefahren und hat nicht gespinnt.
      braver Junge.

    • Iked, was verstehst Du unter einem halb defekten Querlenker ?

      entweder der is im A.sch, oder eben nich, oder meinst Du, die Lagerung hat leichtes Spiel ?

      hat / hätte aber keinen Einfluss auf das DSC Gerümpel und dessen Sensorik.

    • Ja...er scheint ausgeschlagen zu sein.. die zugstrebe vorne links. Eventuell war es auch zufall aber beim langsamen rechts abbiegen kam halt das poltergeräusch von vorne links, wegen der ausgeschlagenen zugstrebe und genau dann auch wieder der totalausfall. Dachte, dass es eventuell einen zusammenhang gäbe. Aber ich bin zuversichtlich, dass es nur das szl ist...hoffentlich :D

      Gesendet von meinem GT-I9300 mit Tapatalk 2

      saftig cre

    • Habe heute mal Zeit gefunden und das Schaltzentrum Lenksäule unter die Lupe nehmen können.

      Ähnlich den gefundenen Lösungen im Internet (m5board.com/vbulletin/e60-m5-e…ensor-diy-fix-worked.html und bimmerfest.com/forums/showthread.php?t=536369) sah meine Scheibe aus wie ein klebriger Zuckerguss-Donut. Zuerst dachte ich, eventuell hat die Schicht irgendeine Funktion, aber da ich sowieso nichts mehr zu verlieren hatte und ein neues SZL schon bereit lag, hab ich kurzer Hand mit Sidolin alles entfernt und die Scheibe blitz blank gewischt:

      [IMG:http://www.abload.de/img/2013-06-2915.19.113bs8m.jpg]

      Außerdem hab ich noch die Lötstellen alle einmal erhitzt, sodass eventuell kalte Stellen wieder geschlossen werden.

      Alles eingebaut wieder und was soll ich sagen, bisher ist der Fehler nicht mehr aufgetreten. Das heisst zwar noch nichts, aber ich bin guter Dinge. Das neue SZL kann ich wohl wieder zurückgeben hoffentlich :>

      saftig cre

    • Hi , hatte gestern auch das gleiche Problem und es war mir fast bekannt also SZL auseinander gebaut und scheibe war echt voll klebrig und voller kleiner Pinkel, so nun sauber gemacht und alles wieder zusammen genaut. Noch Lenkwinckelsensor neu kalibriert und Fehlerspeicher gelöscht und schon ist das Problem weg ;):thumbsup::thumbsup::thumbsup:

      "Bimmer Coding Hamburg "
      TV/DVD Freischaltung während der Fahrt
      Gurtwarner deaktiveren uvm.
      auch Fxx Modelle

      Codierung in Hamburg und Umgebung möglich "PM an mich"
    • Hab genau das selbe problem war gestern beim :) auslesen und xenon einstellen...

      Er hat mir gesagt das der Lenkwinkelsensor defekt ist er versuchte ihn zwar neu anzulernen da es sein kann das er bei "unterspannung" seine werte verleiert aber half nix ...

      Muß wohl ein neuer her...


      Send by iPhone

      Biete Tachoumbau in Wien an
      Biete Hilfestellung bei kleineren Wartungsarbeiten wie Bremsentausch,Ölwechsel udgl...
      Bei Interesse PM an mich...
    • Ups hab paar antworten ubersehn...

      Kann man also richten das Teil???
      Wo war die klebrige stelle oben auf der runden scheibe???
      Einfach reinigen nachloten und hoffen???

      Wie ist der ausbau???
      Airbag ab,Lenkrad ab und den schmarrn ausbauen???


      Send by iPhone

      Biete Tachoumbau in Wien an
      Biete Hilfestellung bei kleineren Wartungsarbeiten wie Bremsentausch,Ölwechsel udgl...
      Bei Interesse PM an mich...
    • Wenn es der selbe Fehler ist, wie wir ihn hatten, hast du gute Chancen ja..

      Die klebrige Schicht ist auf dieser gesamten runden Disk, die du auf meinem Foto siehst. Habe die Scheibe gereinigt und die Lötstellen vom Sensor und der IR LED nachgelötet (ohne neues Zinn, nur neu erwärmt).
      Die Schicht siehst und fühlst du direkt, wenn du das SZL geöffnet hast. Sieht aus wie Zuckerguss mit kleinen Pickeln :D

      Ausbau ist genau so wie du sagst. Airbag runter, Lenkrad ab, Lenksäulenverkleidung unten und oben ab (ist nur geklippst) und dann 4 Schrauben am SZL lösen. Dann kann man das Teil so zu sich ziehen.
      Aufm Schreibtisch dann einfach zerlegbar, Wickelfeder abklippsen und der Deckel ist auch nur geklippst. Dadrunter ist dann schon die besagte Scheibe.

      Batterie abklemmen am besten. Lenkwinkelsensor musste bei mir nichtmal neu kalibriert werden.

      saftig cre

    • Na ich hoffs werd mich nachste woche mal dran machen...
      Womit hast dus gereinigt???
      Geht alkohol auch oder zB fensterputzmittel...
      Wie haben in der Firma geschatzte 1000 mittel fur jeden Dreck von ätzend bis babypopo gg...
      Jetzt eben die frage was ich nehmen kann...


      Send by iPhone

      Biete Tachoumbau in Wien an
      Biete Hilfestellung bei kleineren Wartungsarbeiten wie Bremsentausch,Ölwechsel udgl...
      Bei Interesse PM an mich...
    • Lieber Baby Popo als ätzend. Ich hab Sidolin Fensterreiniger genommen (mit Alkohol). Damit ging das gut. Ich glaube du kannst aber auch einfach Wasser nehmen oder irgendwas, was grad da ist. Nur nichts ätzendes, damit das Plastik nicht angegriffen wird..

      saftig cre

    • ANZEIGE